chat: italic, bold, etc. markdown styling can't span a ship name

ritfed-tabryg created this issue on 2021-08-25 · The issue is replied 0 times

See the last line of the following image. I would expect for the entire line to be italicized, but because of the special treatment/linkification of `@p`s the message is broken up into two segments, each of which having one of the two asterisks necessary to italicize a region. I'm pretty sure the same applies for bold styling as well.

Landscape chat in which the last line should be italicized, but isn't because the italic block is interrupted by a ship name

For what it's worth, I'm using Chromium on Linux with base hash ggnko (from the development stream).

commit: urbit/[email protected]7e70d52

More Details About Repo
Owner Name urbit
Repo Name landscape
Full Name urbit/landscape
Language
Created Date 2020-04-20
Updated Date 2021-10-11
Star Count 19
Watcher Count 7
Fork Count 5
Issue Count 253

YOU MAY BE INTERESTED

Issue Title State Comments Created Date Updated Date Closed Date
Incorrect expectation in co19/LanguageFeatures/Constructor-tear-offs/tearing_off_from_typedef_A07_t01 closed 0 2021-08-09 2021-11-22 2021-08-10
storage: failed to insert feedback from a new user closed 2 2021-11-03 2021-11-15 2021-11-05
hello, everyone, I create a code generator for this CleanArchitecture project open 1 2021-08-18 2021-11-16 -
Continue CommandSequence after Exception in GetCommand open 4 2021-07-19 2021-11-21 -
NVlink for tensorflow2.5, linux, 3090 GPU closed 4 2021-09-30 2021-11-19 2021-10-18
Dialog: DOM memory leak closed 9 2021-10-27 2021-10-21 2021-10-27
3P Media: Get correct `baseColor` from API response open 2 2021-11-11 2021-11-13 -
Failed to got 'p256' closed 4 2021-07-03 2021-11-04 2021-07-06
Gitcoin Quests Landing Page Refresh open 1 2021-06-30 2021-11-27 -
Composer Installers 2.0 closed 0 2021-08-15 2021-11-05 2021-10-23